After continued monitoring for the past hour we have decided to resolve this incident. If you still experience post incident symptoms, please submit a case outlining details of the incident and we will investigate further in the case.
Posted Apr 08, 2026 - 18:46 UTC
Update
We have implemented a fix, and after continued monitoring the latency has been alleviated. If you are still experiencing latency, please submit a case to detailing what symptoms are shown during operations. Once this status message is closed, further details concerning this issue will be communicated over any open cases.
Posted Apr 08, 2026 - 17:32 UTC
Investigating
Certain sites may be experiencing latency when performing actions. We are currently investigating and will update when we have more information.
Thank you for your patience.
Posted Apr 08, 2026 - 16:36 UTC
This incident affected: QubIt (Qubit Service, Qubit Public API).