Potential Product Update Latency

Incident Report for AutoStore

Resolved

Fix has been deployed and team has monitored over the last hour. Setting to resolve.
Posted Jun 11, 2026 - 01:03 UTC

Identified

Root cause has been identified and is being worked on for resolution.
Posted Jun 10, 2026 - 23:07 UTC

Investigating

The team is investigating performance degradation related to Creating/Updating Products / Catalog Import. Processing times may be slow for product updates during this time.
Posted Jun 10, 2026 - 20:28 UTC
This incident affected: QubIt (Qubit Service, Qubit Public API).